Marshall JMP 2203

Hey, that’s a nice amp !

Marshall Master Model Lead 100W Mk2Master model lead 100W Mk2

Marshall Master Model Lead 100W Mk2 backplate

Marshall Master Model Lead 100W Mk2 3

Marshall Master Model Lead 100W Mk2 4Marshall Master Model Lead 100W Mk2 PCB 1Marshall Master Model Lead 100W Mk2 PCB 2Filter caps to be replaced (this amp dated 1977), and parasitic noise on the Hi input …

parasites

parasites 2

Parasites were due to bad anode resistors value : they are marked 100k (as in the schematic, see below), but when measured, Ra for the first triode (Hi input) was > 1M and Ra for the triode corresponding to the Lo input (or second triode if you use the Hi input) was 150k. Once replaced with fresh ones (100k), no longer parasites !

Marshall JMP 2203 bad anode resistors values

Marshall JMP 2203 100k replaced100k anode replaced

Marshall JMP 2203 recappedRecapped !

Schematic JMP : Marshall 2203 Preamp schematicPreamp

Marshall 2203 amp psu schematicAmp and PSU

JCM 800 2203 : quite the same as the JMP 2203, and better readable !

Website Pin Facebook Twitter Myspace Friendfeed Technorati del.icio.us Digg Google StumbleUpon Premium Responsive

This entry was posted in Amps and tagged , . Bookmark the permalink.

5 Responses to Marshall JMP 2203

  1. Robert Delaney says:

    I have the exact same amp, it’s getting an oscillation when the preamp control is above 7,
    even with the master at 0. [with the guitar going straight into the amp]
    When I connect my pedal board, It doesn’t oscillate and I can turn the preamp up all the way without a problem.
    Any suggestions would be appreciated.

  2. t-geek says:

    Oscillation is pain in the a* to debug (as it is for hum and other noise) …

    Does it oscillate with nothing connected in the input ? (You use Hi input, right ?)
    Does it oscillate with an other guitar connected ?

    • Robert Delaney says:

      It will happen on the high input even with just a guitar cord plugged in. [again master volume can even be at zero]
      symptom the same with other guitars tested. haven’t checked the 100k anode resistors mentioned above.

  3. t-geek says:

    Maybe you could try C2 (100pF) see JCM800 schematic ?

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>